четверг, 12 марта 2009 г.

Too good to be true!

/*

Dear Ladies and Gents,
version "3.0.6" of openSUSE-Enlightenment (SOAD project) is out:

Download page

GWDG mirror will be updated to the version "3.0.6" on Monday (next week).

Changelog from 3.0.5 to 3.0.6 version
* new updated kernel (version 2.6.27.19_3.2)
* updated EFL/E to svn_r39423 (20090309)
* updated OOo (version 3.0.1.3)
* fixed "Del" key operation in "xterm"
* "aircrack-ng" added with extended set of documentation (look into "/usr/share/doc/")
* fixed the segfault during the first login to Enlightenment-DR17
* improved "Wicd" init script
* added GTK+ "Unity" theme
* removed "atl1e" driver for "Attansic" LAN cards (found on the eeepc1000* mostly)
* following drivers are added: "rtl8187", "rt73", "rt61", "r8101", "r8168"
* improved list of a default installed repositories
* overall code/software/packages update to the current openSUSE-11.1 state
* other misc. enhancements

In general - this version just works. The only disadvantage is that "LiveCD" version require 800M media (or a blank DVD-R/RW disk) and cannot be recorded to the standard 700M CD-R/RW. The absence of a "delta" images are due to the huge update of a packages - "delta" just has no sense this time.

We're also recommend you to visit our two new modest wiki pages and read a bit about:
Ecomorph
Wicd

Btw, it looks like "Wicd" have a chance to be a default network configuration tool for KDE-4.3 (Dev. Team are constantly improving the package, that's great!).

LiveCD: list of installed packages
USB-stick: list of installed packages

Huge thanks to Mikhail Kazakov for a help in preparation of this release version!

Enjoy!

P.S. The curious persons are welcome to glimpse at the small "Detailed uncompressed LiveCD packages size" pdf file.

***********************************************

Дамы и Господа,
версия "3.0.6" проекта SOAD доступна для Пользователей:

Страница загрузки

Простите, что LiveCD не уложился в 700Mb - новое ядро + жестокий падейт драйверов для звуковых карт никак не позволяет ввернуть Продукт в милый сердцу объём (0.7 на рыло). Вот вам расклад, как мы докатились до жизни такой.

"А в очтальном, прекрасная Маркиза, всё хорошо! Всё хо-ро-шо!" (Утёсов).

Так что пользуйте флешки. Для установки SOAD нужна флеха "объёмом" от 1-го Gb (эт копьё) и более.

Огромное СПАСИБО Михаилу Казакову за помощь в подготовке этого релиза!

Удачи!

*/

11 комментариев:

Алексей комментирует...

большое человеческое спасибо! будем поглядеть )))

Flaming комментирует...

А после сией установки на флешку более одного гигабайта (в даннном случае 4) остальное пространство (в моём случае 3 гектара) куда денется? Останется свободным на этом же разделе, или будет неразмеченным? И стоит создать новый раздел? Или расширить текущий? И будет ли после этого liveflash работать?

sda комментирует...

А после сией установки на флешку более одного гигабайта
на сегодня ситуация такова, что сколько бы ни было на флешке - система "скушает" всё. при первом буте идёт ресайз r/w партиции на всё оставшееся (от партиции r/o) место на флешке. сейчас (спасибо Михаилу Казакову) тестируем скрипт, который сперва будет "отрезать" первую партицию (vfat/?btfs?) для работы с виндой, а всё, что останется, займёт SOAD. наверное следующий релиз пойдёт уже с этими патчами.

HighwayStar комментирует...

Посмотрел тут LiveCd 3.1.0

Из глюков могу рассказать об отсутсвующем русском шрифте в меню xine и в его настройках

На десктопе лежит Welcome.pdf, так вот если попытаться его открыть то E спрашивает чем же его открывать

Не понрравилось выбирать приложения для помещения в кикланч изх огромного списка. ИМХО раньше было лучше. когда квикланч уже был готовый

Еще в ядре есть два одинаковых модуля - /lib/modules/2.6.27.19-3.2-default/update/rtl8187se.ko а второй /lib/modules/2.6.27.19-3.2-default/kernel/drivers/staging/rtl8187se/rtl8187se.ko

В ядре 2.6.27.19 от openSUSE уже есть rtl8187.ko и ставить отдельно модулем его больше не нужно

HighwayStar комментирует...

Да на MSI Wind u90 в 3.1.0 у меня работает WiFi и ethernet.

Wicd отлично справился с вайфаем, подключившись без проблем к сети с WAP2.

Алексей комментирует...

а подскажите как уменьшить системный шрифт + при запуске тогоже OOo или огнелиса нижняя бортовая панель перекрывает запущеное приложение, как можно сделать, чтоб оно пряталось на задний план?

Алексей комментирует...

и ещё вопрос: чем можно ходить на фтп ресурсы с кодировкой cp1251?

sda комментирует...

панельки можно поставить на autohide, приладой lxappearance быстро поменять шрифт в gtk+ , а для ftp есть mc (export LC_ALL=cp1521 && mc), есть curlftpfs (шаблон вызова):

#!/bin/sh
mkdir -p ~/tmp/loop
if [ "`mount | grep /home/sda/tmp/loop`" == "" ] ; then
sudo curlftpfs ftp://$1 ~/tmp/loop -o codepage=cp1251,uid=1000,gid=100,allow_other
else sudo fusermount -u ~/tmp/loop && \
sudo curlftpfs ftp://$1 ~/tmp/loop -o codepage=cp1251,uid=1000,gid=100,allow_other \
|| { echo "error occured" && exit ; }
fi

или вагон + маленькая тележка клиентов, реализованных как плагины к Firefox.

Алексей комментирует...

пытаюсь поставить русский пакет яста пиши zypper install yast-trans-ru, коммандная строка отвечает rpmdb: /var/lib/Packages: fille size not a multiple of the pagesize Ошибка: невозможно открыть индекс Packages испльзуя db3 - Недопустимы аргумент (22) Инициализация не удалась: Rpm Exception

С чем может быть связано такое поведение системы?

sda комментирует...

Алексей
с тем, что Вы ставите пакет на "флешку". по-хорошему это баг, который мы пофиксим (надеюсь) в следующем релизе. там простой конфликт из-за использования "гибридной" файловой системы (часть в ro, часть в rw и объединение aufs+unionfs)

Алексей комментирует...

спасибо за разъяснения - значит при установке на PC всё должно быть :) спасибо попробую